Error Raised But The Message Was Not Found

Problem Description

When performing even basic operations with CUSTOMTOOLS like login to the CUSTOMTOOLS database or saving a SOLIDWORKS document, the user may encounter an error message having the following format:

Error errorNumber, severity severityIdentifier, state stateIdentifier was raised, but no message with that error number was found in sys.messages. If error is larger than 50000, make sure the user-defined message is added using sp_addmessage.

For example, while CUSTOMTOOLS tries to read attributes from the database the error message that appears is the following in English:

Error 150010, severity 16, state 72 was raised, but no message with that error number was found in sys.messages. If error is larger than 50000, make sure the user-defined message is added using sp_addmessage.

Cause of the Problem

This error is caused because the message libraries used by CUSTOMTOOLS operations does not exist in the SQL Server the CUSTOMTOOLS database is running at.

Solution

To solve this problem, create a new database to your CUSTOMTOOLS database server using the CUSTOMTOOLS Administration. Creation of the new CUSTOMTOOLS database adds the necessary message libraries into the SQL Server.

You do not need to use the database created for anything else. You can even delete the new database created to add the message libraries right after the creation is finished.

Additional Notes

  • The CUSTOMTOOLS message libraries are on the SQL Server level and for that reason the messages are not included in backups taken from the CUSTOMTOOLS databases.
  • If you restore your CUSTOMTOOLS database from a backup set into another SQL Server which have not had CUSTOMTOOLS databases before, you need to add the message libraries to the server using the instructions mentioned in this article.